kubuntu-desktop : Depends: software-properties-kde but it is not going to be installed

Tried to install KDE on Linux Mint but it fails?

pravin@vhcalnplci:~$ sudo apt install kubuntu-desktop
password for pravin:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Here is how I resolved it.

sudo add-apt-repository ppa:kubuntu-ppa/backports
sudo apt-get update
sudo apt-get update && sudo apt-get dist-upgrade
sudo reboot
sudo apt install kubuntu-desktop

pravin@vhcalnplci:~$ sudo apt install kubuntu-desktop
††††password for pravin:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation: †The following packages have unmet dependencies:
kubuntu-desktop : Depends: software-properties-kde but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

  • Install software-properties-kde

pravin@vhcalnplci:~$ sudo apt install software-properties-kde
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:The following packages have unmet dependencies:
software-properties-kde : Depends: python3-software-properties (= 0.96.24.32.9) but 1.8.4 is to be installed
E: Unable to correct problems, you have held broken packages.

  • Install python3-software-properties

pravin@vhcalnplci:~$ sudo apt install -t bionic-updates python3-software-properties
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
plasma-look-and-feel-org-kde-breezedark-desktop qml-module-org-kde-extensionplugin
Use ‘sudo apt autoremove’ to remove them.
Recommended packages:
unattended-upgrades
The following NEW packages will be installed:
python3-software-properties
0 upgraded, 1 newly installed, 0 to remove and 11 not upgraded.
Need to get 23.8 kB of archives.
After this operation, 143 kB of additional disk space will be used.
Get:1 http://mirror.wiru.co.za/ubuntu bionic-updates/main amd64 python3-software-properties all 0.96.24.32.9 [23.8 kB]
Fetched 23.8 kB in 0s (115 kB/s)
Selecting previously unselected package python3-software-properties.
(Reading database … 412627 files and directories currently installed.)
Preparing to unpack …/python3-software-properties_0.96.24.32.9_all.deb …
Unpacking python3-software-properties (0.96.24.32.9) …
Setting up python3-software-properties (0.96.24.32.9) …

  • Now install software-properties-kde

pravin@vhcalnplci:~$ sudo apt install software-properties-kde
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
plasma-look-and-feel-org-kde-breezedark-desktop qml-module-org-kde-extensionplugin
Use ‘sudo apt autoremove’ to remove them.
The following NEW packages will be installed:
software-properties-kde
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 19.6 kB of archives.
After this operation, 148 kB of additional disk space will be used.
Get:1 http://mirror.wiru.co.za/ubuntu bionic-updates/universe amd64 software-properties-kde all 0.96.24.32.9 [19.6 kB]
Fetched 19.6 kB in 0s (44.0 kB/s)
Selecting previously unselected package software-properties-kde.
(Reading database … 412646 files and directories currently installed.)
Preparing to unpack …/software-properties-kde_0.96.24.32.9_all.deb …
Unpacking software-properties-kde (0.96.24.32.9) …
dpkg: error processing archive /var/cache/apt/archives/software-properties-kde_0.96.24.32.9_all.deb (–unpack):
trying to overwrite ‘/usr/share/man/man1/software-properties-kde.1.gz’, which is also in package mintsources 1.8.4
Errors were encountered while processing:
/var/cache/apt/archives/software-properties-kde_0.96.24.32.9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

  • It would fail at this point and you need to forcefully install software-properties-kde_0.96.24.32.9_all.deb

pravin@vhcalnplci:~$ sudo dpkg -i –force-overwrite /var/cache/apt/archives/software-properties-kde_0.96.24.32.9_all.deb
(Reading database … 412646 files and directories currently installed.)
Preparing to unpack …/software-properties-kde_0.96.24.32.9_all.deb …
Unpacking software-properties-kde (0.96.24.32.9) …
dpkg: warning: overriding problem because –force enabled:
dpkg: warning: trying to overwrite ‘/usr/share/man/man1/software-properties-kde.1.gz’, which is also in package mintsources 1.8.4
Setting up software-properties-kde (0.96.24.32.9) …
Processing triggers for desktop-file-utils (0.23+linuxmint5) …
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for man-db (2.8.3-2ubuntu0.1) ..

Finally, it’s done. You can install KDE with:

sudo apt install kubuntu-desktop
Advertisements

2 thoughts on “kubuntu-desktop : Depends: software-properties-kde but it is not going to be installed

  1. Hello there. Since KDE updated things around the way you provided stopped working. Everything goes fine before the `sudo dpkg -i –force-overwrite /var/cache/apt/archives/software-properties-kde_0.96.24.32.9_all.deb` part however when i write it (changing the version number to to latest of course) it returns me this:

    *sudo dpkg -i –force-overwrite /var/cache/apt/archives/software-properties-kde_0.96.24.32.11_all.deb*
    (Reading database … 466351 files and directories currently installed.)
    Preparing to unpack …/software-properties-kde_0.96.24.32.11_all.deb …
    Unpacking software-properties-kde (0.96.24.32.11) …
    dpkg: warning: overriding problem because –force enabled:
    dpkg: warning: trying to overwrite ‘/usr/share/man/man1/software-properties-kde.1.gz’, which is also in package mintsources 1.8.8
    dpkg: dependency problems prevent configuration of software-properties-kde:
    software-properties-kde depends on python3-pyqt5; however:
    Package python3-pyqt5 is not configured yet.
    software-properties-kde depends on qapt-batch; however:
    Package qapt-batch is not configured yet.
    software-properties-kde depends on software-properties-common; however:
    Package software-properties-common is not configured yet.

    dpkg: error processing package software-properties-kde (–install):
    dependency problems – leaving unconfigured
    Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
    Processing triggers for desktop-file-utils (0.23+linuxmint6) …
    Processing triggers for mime-support (3.60ubuntu1) …
    Processing triggers for man-db (2.8.3-2ubuntu0.1) …
    Errors were encountered while processing:
    software-properties-kde

    One thing i should add is i actually did install Kde using Synaptic but it did a error so kde is actually there but doesn’t show me close button menus on anything, that’s why i tried this way so it may be interfering with something, i don’t personally think that’s the problem but im saying this just fyi.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s